CRAN Package Check Results for Package datawizard

Last updated on 2024-07-17 18:53:22 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.12.0 14.76 522.76 537.52 OK
r-devel-linux-x86_64-debian-gcc 0.12.1 10.31 424.22 434.53 OK
r-devel-linux-x86_64-fedora-clang 0.12.1 664.75 NOTE
r-devel-linux-x86_64-fedora-gcc 0.12.1 1097.56 OK
r-devel-windows-x86_64 0.12.0 12.00 316.00 328.00 OK
r-patched-linux-x86_64 0.11.0 18.49 498.20 516.69 OK
r-release-linux-x86_64 0.12.0 14.92 502.50 517.42 OK
r-release-macos-arm64 0.12.0 586.00 OK
r-release-macos-x86_64 0.12.1 995.00 OK
r-release-windows-x86_64 0.12.1 13.00 313.00 326.00 OK
r-oldrel-macos-arm64 0.11.0 533.00 ERROR
r-oldrel-macos-x86_64 0.12.1 838.00 ERROR
r-oldrel-windows-x86_64 0.12.0 11.00 376.00 387.00 OK

Check Details

Version: 0.12.1
Check: Rd cross-references
Result: NOTE Undeclared package ‘performance’ in Rd xrefs Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.11.0
Check: running R code from vignettes
Result: ERROR Errors in running code in vignettes: when running code in ‘tidyverse_translation.Rmd’ ... + FUN.VALUE = logical(1)))) { + evaluate_chunk <- FALSE + } > starwars %>% data_filter(skin_color == "light", eye_color == + "brown") When sourcing ‘tidyverse_translation.R’: Error: could not find function "%>%" Execution halted ‘selection_syntax.Rmd’ using ‘UTF-8’... [1s/1s] OK ‘standardize_data.Rmd’ using ‘UTF-8’... [4s/6s] OK ‘tidyverse_translation.Rmd’ using ‘UTF-8’... failed Flavor: r-oldrel-macos-arm64

Version: 0.12.1
Check: running R code from vignettes
Result: ERROR Errors in running code in vignettes: when running code in ‘tidyverse_translation.Rmd’ ... > if (!all(vapply(pkgs, requireNamespace, quietly = TRUE, + FUN.VALUE = logical(1))) || getRversion() < "4.1.0") { + evaluate_chunk <- FALSE .... [TRUNCATED] > row("Note: In this vignette, we use the native pipe-operator, `|>`, which was introduced in R 4.1. Users of R version 3.6 or 4.0 should replace the ..." ... [TRUNCATED] When sourcing ‘tidyverse_translation.R’: Error: a matrix-like object is required as argument to 'row' Execution halted ‘selection_syntax.Rmd’ using ‘UTF-8’... [1s/2s] OK ‘standardize_data.Rmd’ using ‘UTF-8’... [7s/9s] OK ‘tidyverse_translation.Rmd’ using ‘UTF-8’... failed Flavor: r-oldrel-macos-x86_64